CVE-2024-38474

Updated: 2024-07-11 08:48:02.357509

Description:

Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI. Users are recommended to upgrade to version 2.4.60, which fixes this issue. Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x NONE 0
CVSS Version 3.x HIGH 8.1

Status

OS name Project name Version Score Severity Status Errata Last updated
AlmaLinux 9.2 ESU httpd 2.4.53 8.1 HIGH In Testing 2024-07-12 17:21:35
CentOS 6 ELS httpd 2.2.15 8.1 HIGH Not Vulnerable 2024-07-15 04:49:38
CentOS 7 ELS httpd 2.4.6 8.1 HIGH In Progress 2024-07-12 10:16:37
CentOS 8.4 ELS httpd 2.4.37 8.1 HIGH In Testing 2024-07-17 21:40:21
CentOS 8.5 ELS httpd 2.4.37 8.1 HIGH In Testing 2024-07-18 11:23:11
CentOS Stream 8 ELS httpd 2.4.37 8.1 HIGH In Progress 2024-07-12 10:16:37
CloudLinux 6 ELS httpd 2.2.15 8.1 HIGH Not Vulnerable 2024-07-15 04:49:38
Oracle Linux 6 ELS httpd 2.2.15 8.1 HIGH Not Vulnerable 2024-07-15 04:49:38