CVE-2023-34256

Updated: 2024-04-10 21:39:35.531064

Description:

An issue was discovered in the Linux kernel before 6.3.3. There is an out-of-bounds read in crc16 in lib/crc16.c when called from fs/ext4/super.c because ext4_group_desc_csum does not properly check an offset. NOTE: this is disputed by third parties because the kernel is not intended to defend against attackers with the stated "When modifying the block device while it is mounted by the filesystem" access.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x 0
CVSS Version 3.x MEDIUM 5.5

Status

OS name Project name Version Score Severity Status Errata Last updated
AlmaLinux 9.2 ESU kernel 5.14.0 5.5 MEDIUM Ignored 2023-11-08 04:07:17
AlmaLinux 9.2 FIPS kernel 5.14.0 5.5 MEDIUM Ignored 2023-11-21 04:11:53
CentOS 6 ELS kernel 2.6.32 5.5 MEDIUM Ignored 2023-06-08 04:12:24
CentOS 7 ELS kernel 3.10.0 5.5 MEDIUM Ignored 2023-09-19 05:07:23
CentOS 8.4 ELS kernel 4.18.0 5.5 MEDIUM Ignored 2023-06-08 04:12:23
CentOS 8.5 ELS kernel 4.18.0 5.5 MEDIUM Ignored 2023-06-08 04:12:24
CloudLinux 6 ELS kernel 2.6.32 5.5 MEDIUM Ignored 2023-06-08 04:12:24
Oracle Linux 6 ELS kernel 2.6.32 5.5 MEDIUM Ignored 2023-06-08 05:04:41
Ubuntu 16.04 ELS linux 4.4.0 5.5 MEDIUM Released CLSA-2024:1710945589 2024-03-20 11:18:00
Ubuntu 16.04 ELS linux-hwe 4.15.0 5.5 MEDIUM Released CLSA-2024:1710946064 2024-03-20 11:18:02
Total: 11