CVE-2017-9750

Updated: 2022-05-25 08:58:45.750971

Description:

opcodes/rx-decode.opc in GNU Binutils 2.28 lacks bounds checks for certain scale arrays, which allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a crafted binary file, as demonstrated by mishandling of this file during "objdump -D" execution.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x MEDIUM 6.8
CVSS Version 3.x HIGH 7.8

Status

OS name Project name Version Score Severity Status Errata Last updated
CentOS 6 ELS binutils 2.20 7.8 HIGH Ignored 2021-11-02 21:02:48
CloudLinux 6 ELS binutils 2.20 7.8 HIGH Ignored 2021-11-02 21:02:48
Oracle Linux 6 ELS binutils 2.20 7.8 HIGH Ignored 2021-11-02 21:02:48
Ubuntu 16.04 ELS binutils 2.26 7.8 HIGH Released CLSA-2021:1635459139 2021-11-02 21:02:48