CVE-2017-14333

Updated: 2022-05-25 08:13:58.857791

Description:

The process_version_sections function in readelf.c in GNU Binutils 2.29 allows attackers to cause a denial of service (Integer Overflow, and hang because of a time-consuming loop) or possibly have unspecified other impact via a crafted binary file with invalid values of ent.vn_next, during "readelf -a" execution.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x MEDIUM 4.3
CVSS Version 3.x HIGH 7.8

Status

OS name Project name Version Score Severity Status Errata Last updated
CentOS 6 ELS binutils 2.20 7.8 HIGH Released CLSA-2021:1638803819 2022-05-05 12:02:58
CloudLinux 6 ELS binutils 2.20 7.8 HIGH Released 2021-12-06 11:56:04
Oracle Linux 6 ELS binutils 2.20 7.8 HIGH Released CLSA-2021:1637770725 2021-11-24 13:55:53
Ubuntu 16.04 ELS binutils 2.26 7.8 HIGH Released CLSA-2021:1635459139 2021-11-02 21:02:48