Release Info

Advisory: CLSA-2022:1646060667

OS: CentOS 8.4 ELS

Public date: 2022-02-28

Project: gcc

Version: 8.4.1-1.el8.4.tuxcare.els1

Errata link: https://errata.cloudlinux.com/centos8.4-els/CLSA-2022-1646060667.html

Changelog

- CVE-2021-42574: Developer environment: Unicode's bidirectional (BiDi) override characters can cause trojan source attacks (#2008391) - CVE-2018-20673: libiberty: Integer overflow in demangle_template() function (#1668394)

Update

Update command: dnf update gcc*

Packages list

libstdc++-static-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm liblsan-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libstdc++-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libstdc++-docs-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libquadmath-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libgomp-offload-nvptx-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm gcc-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm gcc-gdb-plugin-8.4.1-1.el8.4.tuxcare.els1.i686.rpm liblsan-static-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm gcc-gdb-plugin-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libgfortran-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libatomic-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libtsan-static-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libgomp-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libubsan-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libquadmath-devel-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libgcc-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libasan-8.4.1-1.el8.4.tuxcare.els1.i686.rpm gcc-offload-nvptx-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm gcc-plugin-devel-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libubsan-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libitm-static-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libasan-static-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libgfortran-static-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libgfortran-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libasan-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm gcc-gfortran-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libquadmath-devel-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libtsan-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libgomp-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libatomic-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libatomic-static-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libquadmath-static-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libquadmath-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libstdc++-static-8.4.1-1.el8.4.tuxcare.els1.i686.rpm gcc-plugin-devel-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libitm-devel-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libstdc++-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libgcc-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libstdc++-devel-8.4.1-1.el8.4.tuxcare.els1.i686.rpm libitm-8.4.1-1.el8.4.tuxcare.els1.i686.rpm gcc-c++-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libitm-devel-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libitm-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm cpp-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libstdc++-devel-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libubsan-static-8.4.1-1.el8.4.tuxcare.els1.x86_64.rpm libatomic-static-8.4.1-1.el8.4.tuxcare.els1.i686.rpm

CVEs

CVE-2018-20673
CVE-2021-42574