CVE-2024-25617

Updated: 2024-03-06 10:06:57.121143

Description:

Squid is an open source caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Collapse of Data into Unsafe Value bug ,Squid may be vulnerable to a Denial of Service attack against HTTP header parsing. This problem allows a remote client or a remote server to perform Denial of Service when sending oversized headers in HTTP messages. In versions of Squid prior to 6.5 this can be achieved if the request_header_max_size or reply_header_max_size settings are unchanged from the default. In Squid version 6.5 and later, the default setting of these parameters is safe. Squid will emit a critical warning in cache.log if the administrator is setting these parameters to unsafe values. Squid will not at this time prevent these settings from being changed to unsafe values. Users are advised to upgrade to version 6.5. There are no known workarounds for this vulnerability. This issue is also tracked as SQUID-2024:2


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x NONE 0
CVSS Version 3.x HIGH 8.6

Status

OS name Project name Version Score Severity Status Errata Last updated
CentOS 6 ELS squid 3.1.23 8.6 HIGH Released CLSA-2024:1711491615 2024-04-09 11:13:47
CentOS 8.4 ELS squid 4.11-4 8.6 HIGH Released CLSA-2024:1710436895 2024-03-14 14:09:08
CentOS 8.5 ELS squid 4.15-1 8.6 HIGH Released CLSA-2024:1710436968 2024-03-14 14:09:07
CloudLinux 6 ELS squid 3.1.23 8.6 HIGH Released CLSA-2024:1711491915 2024-04-09 11:13:47
Oracle Linux 6 ELS squid 3.1.23 8.6 HIGH Released CLSA-2024:1711492242 2024-03-26 21:50:00
Ubuntu 16.04 ELS squid 3.5.12-1 8.6 HIGH Released CLSA-2024:1710436449 2024-03-14 14:09:08
Ubuntu 18.04 ELS squid 3.5.27-1 8.6 HIGH Released CLSA-2024:1710789017 2024-03-18 17:09:58