CVE-2024-21485

Updated: 2024-02-11 03:37:24.567173

Description:

Versions of the package dash-core-components before 2.13.0; all versions of the package dash-core-components; versions of the package dash before 2.15.0; all versions of the package dash-html-components; versions of the package dash-html-components before 2.0.16 are vulnerable to Cross-site Scripting (XSS) when the href of the a tag is controlled by an adversary. An authenticated attacker who stores a view that exploits this vulnerability could steal the data that's visible to another user who opens that view - not just the data already included on the page, but they could also, in theory, make additional requests and access other data accessible to this user. In some cases, they could also steal the access tokens of that user, which would allow the attacker to act as that user, including viewing other apps and resources hosted on the same server. **Note:** This is only exploitable in Dash apps that include some mechanism to store user input to be reloaded by a different user.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x 0
CVSS Version 3.x MEDIUM 5.4

Status

OS name Project name Version Score Severity Status Errata Last updated
Ubuntu 16.04 ELS dash 0.5.8 5.4 MEDIUM Ignored 2024-02-12 04:08:37
Ubuntu 18.04 ELS dash 0.5.8 5.4 MEDIUM Ignored 2024-02-12 04:08:37