CVE-2023-6004

Updated: 2024-02-23 19:53:18.386676

Description:

A flaw was found in libssh. By utilizing the ProxyCommand or ProxyJump feature, users can exploit unchecked hostname syntax on the client. This issue may allow an attacker to inject malicious code into the command of the features mentioned through the hostname parameter.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x 0
CVSS Version 3.x MEDIUM 4.8

Status

OS name Project name Version Score Severity Status Errata Last updated
AlmaLinux 9.2 ESU libssh 0.10.4 4.8 MEDIUM In Testing 2024-02-20 13:12:30
CentOS 8.4 ELS libssh 0.9.4 4.8 MEDIUM In Testing 2024-02-20 08:27:38
CentOS 8.5 ELS libssh 0.9.4 4.8 MEDIUM In Testing 2024-02-20 08:27:38
Ubuntu 16.04 ELS libssh 0.6.3 4.8 MEDIUM In Testing 2024-02-19 13:08:29
Ubuntu 18.04 ELS libssh 0.8.0 4.8 MEDIUM In Testing 2024-02-14 20:47:51