CVE-2023-5178

Updated: 2024-04-03 20:45:45.62615

Description:

A use-after-free vulnerability was found in drivers/nvme/target/tcp.c` in `nvmet_tcp_free_crypto` due to a logical bug in the NVMe/TCP subsystem in the Linux kernel. This issue may allow a malicious user to cause a use-after-free and double-free problem, which may permit remote code execution or lead to local privilege escalation.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x 0
CVSS Version 3.x CRITICAL 9.8

Status

OS name Project name Version Score Severity Status Errata Last updated
AlmaLinux 9.2 ESU kernel 5.14.0 9.8 CRITICAL Released CLSA-2024:1712263970 2024-04-07 09:56:49
AlmaLinux 9.2 FIPS kernel 5.14.0 9.8 CRITICAL Released CLSA-2024:1712570434 2024-04-08 10:43:25
CentOS 6 ELS kernel 2.6.32 9.8 CRITICAL Not Vulnerable 2023-12-26 13:10:07
CentOS 7 ELS kernel 3.10.0 9.8 CRITICAL Needs Triage 2023-11-10 23:27:04
CentOS 8.4 ELS kernel 4.18.0 9.8 CRITICAL Released CLSA-2023:1701963303 2023-12-07 13:10:16
CentOS 8.5 ELS kernel 4.18.0 9.8 CRITICAL Released CLSA-2023:1701962635 2023-12-07 13:10:17
CloudLinux 6 ELS kernel 2.6.32 9.8 CRITICAL Needs Triage 2023-11-10 23:27:00
Oracle Linux 6 ELS kernel 2.6.32 9.8 CRITICAL Not Vulnerable 2023-12-26 13:10:07
Ubuntu 16.04 ELS linux 4.4.0 9.8 CRITICAL Not Vulnerable 2023-11-27 08:38:56
Ubuntu 16.04 ELS linux-hwe 4.15.0 9.8 CRITICAL Not Vulnerable 2023-11-27 08:38:59
Total: 11