Updated: 2023-12-29 02:46:18.774393


Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.



Severity Score
CVSS Version 2.x 0
CVSS Version 3.x HIGH 7.5


OS name Project name Version Score Severity Status Errata Last updated
CentOS 6 ELS squid34 3.4.14 7.5 HIGH Released CLSA-2023:1701286147 2023-12-08 16:10:09
CentOS 8.4 ELS squid 4.11-4 7.5 HIGH Released CLSA-2023:1700592773 2023-11-21 16:10:30
CentOS 8.5 ELS squid 4.15-1 7.5 HIGH Released CLSA-2023:1700592975 2023-11-21 16:10:29
CloudLinux 6 ELS squid34 3.4.14 7.5 HIGH Released CLSA-2023:1701376275 2023-12-11 08:43:03
Oracle Linux 6 ELS squid34 3.4.14 7.5 HIGH Released CLSA-2023:1701285122 2023-11-29 16:09:43
Ubuntu 16.04 ELS squid 3.5.12-1 7.5 HIGH Not Vulnerable 2023-11-16 02:30:16
Ubuntu 18.04 ELS squid 3.5.27-1 7.5 HIGH Not Vulnerable 2023-11-16 02:30:16