CVE-2023-46589

Updated: 2024-01-05 19:47:27.148441

Description:

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x 0
CVSS Version 3.x HIGH 7.5

Status

OS name Project name Version Score Severity Status Errata Last updated
Ubuntu 18.04 ELS tomcat8 8.5.39-1 7.5 HIGH Released CLSA-2024:1705081413 2024-01-12 13:09:34
Ubuntu 18.04 ELS tomcat9 9.0.16-3 7.5 HIGH Released CLSA-2024:1707420277 2024-02-08 16:10:28