CVE-2022-3705

Updated: 2023-11-07 19:33:41.720139

Description:

A vulnerability was found in vim and classified as problematic. Affected by this issue is the function qf_update_buffer of the file quickfix.c of the component autocmd Handler. The manipulation leads to use after free. The attack may be launched remotely. Upgrading to version 9.0.0805 is able to address this issue. The name of the patch is d0fab10ed2a86698937e3c3fed2f10bd9bb5e731. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-212324.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x 0
CVSS Version 3.x HIGH 7.5

Status

OS name Project name Version Score Severity Status Errata Last updated
CentOS 6 ELS vim 7.4.629 7.5 HIGH Not Vulnerable 2022-11-08 10:03:25
CloudLinux 6 ELS vim 7.4.629 7.5 HIGH Not Vulnerable 2022-11-08 10:03:25
Oracle Linux 6 ELS vim 7.4.629 7.5 HIGH Not Vulnerable 2022-11-08 10:03:26
Ubuntu 16.04 ELS vim 7.4.1689-3 7.5 HIGH Not Vulnerable 2022-11-08 10:03:25