CVE-2022-25258

Updated: 2023-11-07 19:06:45.874548

Description:

An issue was discovered in drivers/usb/gadget/composite.c in the Linux kernel before 5.16.10. The USB Gadget subsystem lacks certain validation of interface OS descriptor requests (ones with a large array index and ones associated with NULL function pointer retrieval). Memory corruption might occur.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x MEDIUM 4.9
CVSS Version 3.x MEDIUM 4.6

Status

OS name Project name Version Score Severity Status Errata Last updated
AlmaLinux 9.2 ESU kernel 5.14.0 4.6 MEDIUM Ignored 2023-11-08 04:07:41
AlmaLinux 9.2 FIPS kernel 5.14.0 4.6 MEDIUM Ignored 2023-11-21 04:12:18
CentOS 6 ELS kernel 2.6.32 4.6 MEDIUM Not Vulnerable 2022-03-30 18:48:19
CentOS 8.4 ELS kernel 4.18.0 4.6 MEDIUM Not Vulnerable 2022-03-10 14:52:02
CentOS 8.5 ELS kernel 4.18.0 4.6 MEDIUM Not Vulnerable 2022-03-10 14:52:02
CloudLinux 6 ELS kernel 2.6.32 4.6 MEDIUM Not Vulnerable 2022-03-30 18:48:19
Oracle Linux 6 ELS kernel 2.6.32 4.6 MEDIUM Not Vulnerable 2022-03-30 18:48:19
Ubuntu 16.04 ELS linux-hwe 4.15.0 4.6 MEDIUM Ignored 2022-09-28 08:02:37
Ubuntu 16.04 ELS linux 4.4.0 4.6 MEDIUM Released CLSA-2022:1667414297 2022-11-02 17:06:46
Ubuntu 18.04 ELS linux 4.15.0 4.6 MEDIUM Ignored 2023-03-02 04:04:09