CVE-2017-7226

Updated: 2022-05-25 08:33:34.060157

Description:

The pe_ILF_object_p function in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.28, is vulnerable to a heap-based buffer over-read of size 4049 because it uses the strlen function instead of strnlen, leading to program crashes in several utilities such as addr2line, size, and strings. It could lead to information disclosure as well.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x MEDIUM 6.4
CVSS Version 3.x CRITICAL 9.1

Status

OS name Project name Version Score Severity Status Errata Last updated
CentOS 6 ELS binutils 2.20 9.1 CRITICAL Released CLSA-2021:1638803819 2022-05-05 12:02:34
CloudLinux 6 ELS binutils 2.20 9.1 CRITICAL Released 2021-12-06 11:55:26
Oracle Linux 6 ELS binutils 2.20 9.1 CRITICAL Released CLSA-2021:1637770725 2021-11-24 11:55:21
Ubuntu 16.04 ELS binutils 2.26 9.1 CRITICAL Released CLSA-2021:1635459139 2021-11-02 21:02:48