CVE-2016-2226

Updated: 2022-05-25 08:33:30.793397

Description:

Integer overflow in the string_appends function in cplus-dem.c in libiberty allows remote attackers to execute arbitrary code via a crafted executable, which triggers a buffer overflow.


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x MEDIUM 6.8
CVSS Version 3.x HIGH 7.8

Status

OS name Project name Version Score Severity Status Errata Last updated
CentOS 6 ELS binutils 2.20 7.8 HIGH Released CLSA-2021:1640621287 2022-05-05 12:03:44
CloudLinux 6 ELS binutils 2.20 7.8 HIGH Released CLSA-2021:1639670535 2021-12-27 14:17:38
Oracle Linux 6 ELS binutils 2.20 7.8 HIGH Released CLSA-2021:1639670584 2021-12-16 15:55:33
Ubuntu 16.04 ELS binutils 2.26 7.8 HIGH Released CLSA-2021:1635459139 2021-11-02 21:02:48