CVE-2023-3823

Updated: 2023-11-04 21:08:37.394489

Description:

In PHP versions 8.0.* before 8.0.30, 8.1.* before 8.1.22, and 8.2.* before 8.2.8 various XML functions rely on libxml global state to track configuration variables, like whether external entities are loaded. This state is assumed to be unchanged unless the user explicitly changes it by calling appropriate function. However, since the state is process-global, other modules - such as ImageMagick - may also use this library within the same process, and change that global state for their internal purposes, and leave it in a state where external entities loading is enabled. This can lead to the situation where external XML is parsed with external entities loaded, which can lead to disclosure of any local files accessible to PHP. This vulnerable state may persist in the same process across many requests, until the process is shut down. 


Links NIST CIRCL RHEL Ubuntu

Severity

Severity Score
CVSS Version 2.x 0
CVSS Version 3.x HIGH 7.5

Status

OS name Project name Version Score Severity Status Errata Last updated
EL 6 PHP php 7.1 7.5 HIGH Released CLSA-2023:1695502516 2023-09-25 14:22:42
EL 6 PHP php 7.2 7.5 HIGH Released CLSA-2023:1695503125 2023-09-25 14:22:41
EL 6 PHP php 5.2 7.5 HIGH Released CLSA-2023:1695492905 2023-09-25 14:22:45
EL 6 PHP php 5.1 7.5 HIGH Released CLSA-2023:1695478168 2023-09-25 14:22:46
EL 6 PHP php 5.3 7.5 HIGH Released CLSA-2023:1695497854 2023-09-25 14:22:45
EL 6 PHP php 5.4 7.5 HIGH Released CLSA-2023:1695499572 2023-09-25 14:22:44
EL 6 PHP php 5.6 7.5 HIGH Released CLSA-2023:1695500726 2023-09-25 14:22:43
EL 6 PHP php 7.0 7.5 HIGH Released CLSA-2023:1695501891 2023-09-25 14:22:43
EL 6 PHP php 7.3 7.5 HIGH Released CLSA-2023:1695503741 2023-09-25 14:22:41
EL 6 PHP php 7.4 7.5 HIGH Released CLSA-2023:1695504659 2023-09-25 14:22:15
Total: 86